Various Posts on Magento, SEO, Apple and Website design

Brand new 2013 iMac WiFi / Internet speed issues

I have just received my brand new 2013 27 inch iMac. I have been waiting for this moment for about three and a half years - and I am still very excited about it. It is beautiful. I only have 2 minor niggles - I ordered a trackpad but it came with a mouse and the machining of the lower left case where it meets the screen is ever so slightly (and I mean slightly) off. However, I love it - the screen is a leap up from my 2006 iMac and the processor / graphics lightning fast.


After the momentus Apple 'Box-Opening' - I started the process of putting all my software on it. I chose not to mirror my old iMac as I wanted a fresh start. So, having a rapid internet connection I set the iMac up to download about 15Gb and went to bed (Syncing my Dropbox, iCloud bits and bobs, Adobe Creative Suite, Microsoft Office to name but a few).


I must mention at this point that I did exactly the same on a new MacBook Pro about a month ago - so I am well versed in what needs to be downloaded / installed and where from. And that my internet is fast enough to accomplish such a mammoth task overnight. Or so I thought...


Woke up to a VERY slow internet connection. It was apparent straight out of the box - but I figured all the sync'ing with iCloud and the various things I was downloading would have slowed it all down.. 


I became suspicious so I Google'd to see if there was a problem - turns out - there is a problem with iMac internet connection. Quickest way to check is to do a SpeedTest.net test.




Sat side by side by MacBook Pro registered 13.5 Mb down compared to 2 Mb down for my iMac.

There is a fix to this new iMac slow internet connection problem - Change your router channel.

I have a Time Capsule that is running the latest software talking to the latest iMac - so you would hope that Apple could sort this minor inconvenience for us. As Apple does so much else for us; I'm only a bit disappointed when they haven't quite figure EVERYTHING out.

So - the fix. Change your Route signal Channel. If you need a clue on which Channel to select (for 2.5GHz and 5GHz) - Press Option and click on your WIFI symbol on the top right of your screen.. 




And then click on Wireless Diagnostics - an in-built tool that allows you to establish who's using what on the WIFI spectrum and shows you the specifics of what you're using too!! 
Comments (1)